趣味の電子工作などの記録。時にLinuxへ行ったり、ガジェットに浮気したりするので、なかなかまとまらない。※サイト移転しました(tomono.eleho.net ⇒ tomono.tokyo)
RSS icon
  • IdeaPas S10-2にWindows8を入れてみた(おまけ)

    投稿日 2013年 1月 27日 コメントはありません

    その他、IdeaPad S10-2を入れた後でやったことは以下の通りです。

    アンチウイルスソフトの導入

    いつものようにカスペルスキーインターネットセキュリティをインストール。WindowsXP時代からそうですが、パターンファイルの更新が遅いのが不満なところ。

    Google Chromeの導入

    Webブラウザは Google Chrome をいつものように導入

    古いWindowsファイルの削除

    Windowsキー + X を押して、コントロールパネルを起動。「システムとセキュリティ」→「管理ツール」→「ディスク クリーンアップ」を実行。
    新しく開いたウインドウの「システムファイルのクリーンアップ」を押す。
    しばらくまつと「以前のWindowsのインストール」と「一時Windowsインストールファイル」がチェックできるようになるので、チェックして「OK」を押す。
    これで16GBくらい空き領域が増えました。

    ディスクデフラグの実行

    Windowsキー + X を押して、コントロールパネルを起動。「システムとセキュリティ」→「管理ツール」→「ドライブのデフラグと最適化」を実行。
    Cドライブが選択済みの状態なので「最適化」を押すと、Trimコマンドが発行されるようです。(表示にも○○%トリム済みと表示されます)

    タッチパッドドライバのインストール

    やはりブラウザを使っていると縦スクロールは避けられないのだけど、タッチパッドのバーチャルスクロールが動作せずストレスが非常に溜まる。LenovoのページにあるWindows7用のドライバではスクロールが動作しなかった。
    アンインストールしてSynaptics社のページのドライバを入れてみました。設定をイジらないとだめですが、それなりに使えています。ただ、時々反応が悪くなります。LinuxMintではしっかり動くのに何でダメなんでしょうね・・・。


  • IdeaPad S10-2にWindows8を入れてみた

    投稿日 2013年 1月 26日 コメントはありません

    NM70I-847に入れてみたWindows8が思いのほか良さそうだったので、WindowsXPとLinuxMint13のデュアルブートにしていたIdeaPad S10-2にWindows8を入れてみました。

    元々、このPCはHDDからSSDに換装してあったのですが、WindowsXPではSSDに対応していないためかシャットダウンが非常に遅くてイライラさせられていました。(半面、LinuxMintはサクサクだった)
    これは自分の推測では以下の要因で起きているのではないかと思っていました。

    • WindowsXPはSSDに対応していないので暇な時に空きセクタを消去するコマンド(Trimコマンド)を発行せず放置している
    • WindowsXPの終了時には未書込みのデータをたくさん書き出さないといけない
    • ・・・となると、WindowsXPの終了時には空きセクタの消去と書込みをしなければならない。
      (事前に空きセクタを消去してあれば、書込みだけで済む。フラッシュメモリの消去には非常に時間がかかるので、事前に消去しておけるのであればパフォーマンス上の利点は非常に大きいはず。)

    で、画面が狭くてもレジストリ書き変えでなんとか使用可能なようですので、3300円の格安アップグレードができるうちにSSDにしっかり対応しているWindows8 Proにアップグレードしてみることにしました。

    続きを読む »


  • NM70I-847は結局どうなったか

    投稿日 2013年 1月 20日 1つのコメント

    LinutMint13を入れた静かな常時稼働PCを目指すべく導入したBIOSTAR NM70I-847の近況報告です。

    結局、Linux(というか、非Windows)を入れるとこんな感じでした。

    • LinuxMint13 – 不安定
    • LinuxMint14 – 不安定
    • Ubuntu12.10 – 不安定
    • CentOS6.3 – 安定
    • FreeBSD9.0 – 安定(ただしXは入れてない)
    • SystemRescueCD – 安定

    と、何か傾向があることは伺えます。

    なんとなく新しいカーネルが入っているとダメっぽい感じだったのですが、SystemRescueCDのカーネルと、Mint13のカーネルは似たようなバージョンだったので単純にそういうわけでもなさそうです。また、最新のカーネルを kernel.org から取ってきてコンパイルしていれてやってもやっぱりダメなものはダメでした。

    ・・・・で、諦めて Windows8 Pro を入れちゃいました。最近買った ThinkPad Edge 130はWindows7モデルだったのでWindows8 Proへのアップグレード版が1200円で入手できるのですが、優待プログラムのFAQを見ていたところ、

    Screenshot-Windows 8 - FAQ - Google Chrome

    ということで、別のPCにインストールすることも可能であることがわかりました。
    なので、LinuxMint13に入れ替えて使わなくなったWindowsXPをインストールした後、この優待プログラムを使ってWindows8にアップグレードしてしまいました。

    SandyBridgeとはいえ動作周波数は1.1GHzとかなり低くて性能もあまり期待できないはずなのですが、Windows8は意外に軽く動作しています。これはこれでありかもしれません。

    しかも、Windows8自体のバグっぽい現象(アカウントの設定をすると何か変)には見舞われていますが、動作自体は極めて安定しています。

    結局、NM70I-847はメーカーページにあるようにLinux系のOSは動作保証外・・・ということなのでしょう。


  • LinuxMintでSMB共有

    投稿日 2013年 1月 3日 コメントはありません

    年末の恒例行事といえば年賀状の作成ですが、年賀状印刷はLinuxで対応しにくい分野の一つで、やはりWindows版の年賀状作成ソフトに軍配があがってしまいます。
    しかし、図案作成や写真の色やサイズの調整の段階ではLinux + GIMPでの作業で十分です。となると、Windowsマシンとの間でファイルをどうやって受け渡しするかということを考えるのですが、環境に手を加えないで済むのはFreeNAS経由での受け渡しです。しかし、外部のSMBのファイルをマウントしたディレクトリはLinuxMint13標準のCajaや、Ubuntuで採用されているNautilusでは残念ながら画像ファイルをサムネイル表示できません。そこで、LinuxMint側の作業ディレクトリをWindows側に直接見せてやる方法を調べたのでメモしておきます。

    続きを読む »


  • Windows8アップグレードをインストールしてみた

    投稿日 2012年 10月 29日 コメントはありません

    先週金曜日(10/26)にWindows8が発売されました。今回のWindows8はWindows7の時と違ってアップグレード版が期間限定ながら安価に提供されていますので、試しにアップグレード版をインストールしてみました。(Microsoftの罠に嵌ってる??)

    今回はWindowsXP/Vista/7からWindows8 Proへのアップグレードは1月31日までの限定とはいえ、ダウンロード版で3300円と格安に設定されています。おそらく

    • WindowsVistaはもちろんWindows7をもってしても、市場ではWindowsXPが主流のままになっている
    • タッチパネル操作が主流になりつつあるなか、タブレットやスレートではAppleとAndroid(Google)に遅れをとっている
    • (主流ではないでしょうが)UbuntuやCentOS、Debianなど、Windowsと大差ない操作性を実現しているLinuxディストリビューションが出てきている。

    といったところが背景にあるのでしょう。そして、それを挽回するためには早期に普及率を高めて、一般にも浸透させなければならない、という焦りなんでしょうか。
    早期に普及させるには、いわゆるearly adopter層に一気に浸透させるしかない、 ということで、今回の期間限定3300円という施策につながっていると(勝手に)推測します。そしてこの期間にアップグレードしたユーザーには一般ユーザーへの宣伝広告とサポートも期待しているんでしょうね。

    ま、そんなことはともかく、アップグレードインストールしてみました・・・・がいくつか罠があったのでした・・・。

    続きを読む »


  • VirtualBox OSEを試す

    投稿日 2011年 10月 10日 コメントはありません

    以前、QEMUを動かしてみましたが、残念ながら何故かUSB機器が使えませんでした。さらに、共有フォルダも何故か動作せず、外部とのファイル交換ができないため、今度はVirtualBoxにチャレンジしてみたいと思います。

    まず、インストールですが、Synapticで「virtualbox-ose」を選択してインストールするだけです。「ose」はOpen Source Editionの略のようです。

    起動は、「アプリケーション」→「アクセサリ」→「VirtualBox OSE」です。

    起動したら、「新規(N)」でウィザードに沿って仮想マシンと仮想ディスクを作ります。ディスクサイズ、メモリサイズ、ゲストOS等は非常にわかりやすいので、何も悩むところはありません。

    仮想マシンを生成したら、詳細の設定をしていきます。

    1. 設定ボタンを押した後、ストレージを選択し、さらにCDROMのアイコンを押して、CD/DVDデバイスを「ホストドライブ」にして、ホストのドライブをそのまま見せる設定にします。初回起動はシステムのインストールのため、システムの設定で起動順序を「CD/DVD」にします。
    2. ホストとのデータ交換のため、フォルダ追加のアイコンを押してどこをゲストマシンに見せるか設定することで共有フォルダを追加します。
    3. 仮想マシンからホストマシンに戻るにはデフォルトでは右CTRLキーを押す必要があるのですが、自分が使用しているHHKには右CTRLキーがありません。「ファイル」→「環境設定」→「入力」でホストキーを押して、ホストキーに設定するキーを押下します。自分は「右ALTキー」をホストキーに設定しました。

    この状態で 起動ボタンを押すと起動するはず・・・ですが、「VERR_VMX_IN_VMX_ROOT_MODE」というコードを含むエラーが起きて、起動できませんでした。Googleさんに聞いてみると、コマンドラインで

    $ sudo modprobe -r kvm-intel

    とするとよいとのことでしたので、試してみたら起動できました。

    で、インストールを進めていくと、なぜかネットワークコンポーネントのインストール途中でエラーを起こしてリブートしてしまいました。

    ネットワークコンポーネントのインストール中のリブートでしたので、仮想デバイスを変更すると、やはり途中で何か所かエラーは出たものの、インストールが完了しました。

    その後、IE6、Guest Additions、Firefox、Avira AntiVir Personalなどを無事にインストールできました。


  • PCの組み換え

    投稿日 2011年 9月 24日 コメントはありません

    やっと雑用をこなすCore2Quadマシン(Core2Quad Q6600 + Intel DG33BU)の作業環境をCore-i3マシンに移したので、ちょっとCore2Quadマシンをいじり倒してみました。

    このマシンで困っていたのは、

    • 電源投入からBIOS画面表示が異常に長い場合がある
    • シャットダウンがうまく行く場合でも、画面が真っ暗になってから電源断まで2分くらいかかる

    といったことでした。

    で、元々クリーンインストールをしようと思っていたのですが、別のHDDにWindowsXP ServicePack3をクリーンインストールしてみましたが現象が変わりません。

    最初はAHCIをイネーブルにしてAHCIモードでインストールしようとしたのですが、シャットダウン時に電源が切れなくなりました。それどころか、Ubuntuでも同じ症状が出ることがわかりました。つまり、原因はソフトウェアではないわけです。

    マザーボード(DG33BU)について調べてみると、「USB2.0ドライバをインストールすると電源が切れなくなる場合がある。その場合はSATAのモードをLegacyに変更してくれ。」というようなことが書いてありますorz。事実上、「AHCI使えません」って言ってるようなものですが・・・。

    しかし、SATAをLegacyに変更しても直りません。CMOSをクリアしても、BIOSをUpdateしても、Memtestをかけても現象は変わりません。もう、原因はCPUかマザーボード(か電源)しかありません。が、雰囲気的にはマザーボードがおかしいようにしか思えません。(ググってみても、DG33BUはあまりいい話はでてこない)

    多少時間が経ったとはいえ、Core2Quad Q6600 は十分な戦力ですので、捨ててしまうには惜しいです。かといって、いまからLGA775のマザーボードを調達するのもなんだか馬鹿馬鹿しいですし。

    そこでもう1台のオンライントレード用のCore2Duo E7400+GIGABYTE GA-G31M-ES2LマシンとCPUを交換してみることにしました。こちらもG31マザーではあるものの、メモリスロットが2本しかなく4GBしか搭載できませんが、それでもCore2Quad Q6600の性能は捨てがたいので組み替えてみました。

    このE7400マシンは200Wの電源しか積んでいないので、とてもCore2Quad Q6600の95~105WのTDPには耐えられそうもありません。よって、マザーボードの方をスワップする作業になってしまいました。

    変更後のCore2Quad Q6600マシン

    変更後のCore2Duo E7400マシン

    • CPU Core2Duo E7400(2.8GHz×2、VT無効、65W)
    • マザー Intel DG33BU
    • メモリ DDR2-800 2GB×4枚
    • VGA Radeon HD4350
    • 電源 200W SFX

    ビデオカードも一緒に移せればよかったのですが、残念ながら片方はLowProfileのスロットなので、移植できませんでした。

    で、動作確認をしながら一晩かかって組み替え作業をやった結果、BIOS表示が遅かったり、電源断が遅い/できない現象はやはりマザーボードについて回りました。

    その作業の中でわかったのですが、後者の200WSFX電源のケースは、電源FANが軸受けの劣化からか異音がでていたり、ケースFANが回らなかったりしていました。まあ、10年くらい使っているので仕方ないですが。もし手持ちで80mm角のファンがあれば交換してしまうところですが、後からだとFAN2個交換も面倒(しかも片方は電源ユニット内)ですし、このケースは縦置きできないくらい幅が大きいデスクトップケースで邪魔ですし、マザーボードも微妙な状態なので、それぞれのマシンの役割を考えながら、処分を含めて対処を考えたいと思います。処分はそれはそれで面倒なのですが、ただ、安い小型のケース+下位のPentiumGシリーズに置き換えてしまった方が、メンテナンスが楽で速いマシンになりかねないので・・・。


  • QEMU+Qemu Launcher

    投稿日 2011年 9月 20日 コメントはありません

    せっかく仮想化支援機能であるVT-xが使えるCore-i3を導入したので、使ってみたくなりました。

    というわけで、Ubuntuで動く仮想マシンの「qemu」「qemu-kvm」とそのGUIインタフェースである「Qemu Launcher」をSynapticからインストールしました。

    で、使い方ですが、

    1.  qemu-launcherをコマンドラインから起動(メニューからでも起動できるようです)
    2. 「Disks and memory」で
      1)CD-ROMにmountコマンドで調べたマウントポイントを記入します
      2)Hard disk 0 に「New」で「empty QCOW2 image」を作ります
      3)「Use  CD-ROM」にチェックを入れます
      4)「Boot disk」を「CD-ROM」にします
    3. 他のタブを設定します。
      1)キーマップはデフォルトから変更してはいけません
      2)サウンドはお好みでイネーブルにします
    4. 「Lanuch」を押します

    で無事に動きました。(2回目以降はDiskImageを作らなくてもよいはず・・)

    今回は試しにWindows2000をインストールしてみましたが、ドライバも特に必要なく、QEMU自体には特に大きな問題もなくインストールできました。

    ただ、Windows2000自体が古いのでInternetExplorer 5.0 しか入っておらず、MicrosoftのWebサイトも正常に表示できないので6.0へのアップデートやFirefoxのインストールには少々難儀しました。また、アンチウイルスソフトとしてAvira AntiVir Personal をインストールしたのですが、WindowsUpdateとの関係でなかなかうまくいきませんでした。(結局、WindowsUpdateをインストールし直し(?)でうまいくいきましたが・・・・)

    また、WikipediaではUSBが使えそうなことを書いてありますが、とりあえずQemu LauncherのUIの範囲ではそれらしいものは見つかりませんでした。
    ワンチップマイコンの開発ツールでどうしてもWindowsを要求するものもあるので、そういうケースで使えればと思ったのですが、ちょっと残念・・・。

     


  • Z68マシンへのXPインストール(3)

    投稿日 2011年 9月 18日 コメントはありません

    というわけで、500GBのHDDの速度を3Gbpsに制限した状態でWindowsXPのインストール(AHCIドライバを組み込んだCD-ROMを使用)してみたところ、まったく問題なくインストールすることができました。

    Asrockの添付CD-ROMのドライバの組み込みもすんなりいってあっという間でした。一体、この2日間の苦労は何だったんだろう、という感じです。

    最終的には、HDDを差し替えた時のことを考えて、マザーボードのSATA-3のポートではなくSATA-2のポートにHDDを接続することにしました。なんかちょっともったいない感じはしますけど。


  • Z68マシンへのXPインストール(2)

    投稿日 2011年 9月 16日 コメントはありません

    引き続きZ68雑用マシンへのWindowsXPのインストールです。

    WindowsXPのインストーラはHDDを認識するようになったのですが、ファイルのコピー後にリブートした後、通常ならHDDから起動するところでHDDから起動せずに再度CD-ROMから起動してしまいます。こりゃ、お手上げかな、と思って現実逃避していたのですが、ふとAsrockのWebサイトをみてみると、BIOS(UEFI)のアップデートが出ていました。最新版は1.20で、今入っているのは1.10です。なので、アップデートを試してみることにしました。

    1. 4GBのUSBメモリを用意して、FAT32でフォーマットします。
    2. AsrockのWebサイトから最新のBIOS(Instant Flash用)をダウンロードしてきます。
    3. ダウンロードしたファイルをZIP展開してUSBメモリに入れる
    4. USBメモリを挿して電源を入れてBIOS設定画面を出す
    5. 「Advanced」→「Instant Flash」を選択
    6. なんか文字化けしますが、「OK」を押すと「1.20」という表示が入った行が出ますので、押すとアップデートが始まる
    7. アップデート終了後に、再起動してバージョンアップしていることを確認

    です。

    しかし、結果は変わらず・・・。もう、諦めます(笑)。
    <9/18追記>解決できました原因はハードディスクリーダライタがSATA3に対応していないことでした。

    なぜなら、調べてみるとWindowsXPでUEFIをサポートしているのは64bit版のみ。つまり32bit版ではブートの部分が対応してないっぽい気がします。

    雑用はWindows7でも入れてやらせるようにするしかないかな・・・。ただ、NASのSambaとの相性とかで引っかかったりしないか不安だったりします。