Ubuntuで802.11nを動かす(1)うまく動かない・・・

外部(といってもクラスBのプライベートアドレスですが・・・)と接続する環境ができたところで、1台のPCを外部向けに使用することにしました。

スペックは、
CPU:Atom330(DualCoreのAtomです)
メモリ:1GB(初期のAtomマザーなので仕方ない・・・)
外部記憶:HDDは160GB(WindowsXPインストール済み)、USBメモリ8GB(Ubuntu10.04)
といった感じです。

このPCに無線LANアダプタを追加します。あきばお~で1000円で売っていたGW-US300MiniSという802.11n(300Mbps対応)のUSB無線LANアダプタです。

Googleさんに聞いてみると、ドライバをコンパイルしてやらなければならないとかいろいろあるようなのですが、とりあえず無線LANアダプタを挿してlsusbしてみます。すると、

~$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 2019:ab24 PLANEX
Bus 001 Device 002: ID 090c:6200 Feiya Technology Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
~$

という感じで、デバイス自体は認識しているようです。次に、dmesgして最後の部分を見ると、

[   27.629045] eth4: no IPv6 routers present
[ 2030.498246] lo: Disabled Privacy Extensions
[ 2062.932026] usb 1-6: new high speed USB device using ehci_hcd and address 3
[ 2063.080180] usb 1-6: configuration #1 chosen from 1 choice
[ 2063.142880] cfg80211: Calling CRDA to update world regulatory domain
[ 2063.154160] cfg80211: World regulatory domain updated:
[ 2063.154169] (start_freq – end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 2063.154177] (2402000 KHz – 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2063.154183] (2457000 KHz – 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 2063.154190] (2474000 KHz – 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 2063.154196] (5170000 KHz – 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2063.154203] (5735000 KHz – 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2063.277850] phy0: Selected rate control algorithm ‘minstrel’
[ 2063.279622] Registered led device: rt2800usb-phy0::radio
[ 2063.279699] Registered led device: rt2800usb-phy0::assoc
[ 2063.279763] Registered led device: rt2800usb-phy0::quality
[ 2063.280280] usbcore: registered new interface driver rt2800usb
[ 2063.335154] udev: renamed network interface wlan0 to wlan2
[ 2063.343298] rt2800usb 1-6:1.0: firmware: requesting rt2870.bin
[ 2063.622999] ADDRCONF(NETDEV_UP): wlan2: link is not ready

ということで、なんか認識してるっぽいです。

「システム」→「システム管理」→「ネットワークツール」でみると、なんと認識しています。

「システム」→「設定」→「ネットワーク接続」と進んでみますが、何か変です。普通はAP一覧などがみえると思うのですが、そんな感じではありません。

で、Googleさんに聞いてみると、Ubuntu日本語フォーラムでまったく同じ議論がされているようで、正しいドライバはrt2870staなのに、rt2800usbがロードされてしまう、という問題のようです。

~$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 2019:ab24 PLANEX
Bus 001 Device 002: ID 090c:6200 Feiya Technology Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
~$ modinfo rt2800usb | grep 2019
alias:          usb:v2019pAB25d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019pAB24d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019pED06d*dc*dsc*dp*ic*isc*ip*
~$ modinfo rt2870sta | grep 2019
alias:          usb:v2019pAB25d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019pED14d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019pED06d*dc*dsc*dp*ic*isc*ip*
~$

ということで、rta2870staの方にはv2019pAB24がないので、うまくロードされないようです。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)