NanoPi NEO2にOpenMediaVaultをインストール

今度は、NanoPi NEO2にArmbian+OpenMediaVaultをインストールします。

1.Armbianのインストール

イメージはArmbianのNanoPi NEO2のページからArmbian Busterのイメージをダウンロードしてきました。これをMicroSDにディスクイメージライタで書き込んで、NanoPi NEO2にセットします。

電源投入して少し待ったら、SSHで接続します。ユーザー名はroot、初期パスワードは1234です。接続したら、rootパスワードの変更とユーザーの作成を聞いてきますので、適当に設定します。

一度ログアウトしてログインし直してから、apt-get update & apt-get upgrade をかけます。理由がよくわかりませんが、異常に時間がかかりました。、

再起動したら、再度 armbian-config を起動して、タイムゾーンをAsia/Tokyoにセット、ロケールにja_JP.UTF-8を追加、デフォルトロケールはen_US.UTF-8にセット、ホストネームを適当にセットして、一旦リブートします。

2.ArmbianのルートファイルシステムをHDDに移動

MicroSDだといつかブッ飛ぶので、ルートファイルシステムをHDDに移動します。

まず、fdiskでHDDのパーティションを作成します。

今回は30GBをルートパーティション、4GBをスワップ、残りをデータ領域にすることにしました。

Device        Start      End  Sectors Size Type
/dev/sda1      2048 62916607 62914560  30G Linux root (ARM-64)
/dev/sda2  62916608 71305215  8388608   4G Linux swap

フォーマットしておきます。

$ sudo mkfs.ext4 /dev/sda1
$ sudo mkswap /dev/sda2

次にルートファイルシステムをUSB-HDDに移動します。

$ sudo armbian-config

でarmbian-configを起動、systemメニューを選択して「Install」を選択して「1 Boot from SD – system on SATA, USB or NVMe」でUSB-HDDに /dev/sda1 にシステムを移動します。

移動が完了すると、再起動を勧められるので、再起動します。

3.OpenMediaVaultをインストール

$ sudo armbian-config

でarmbian-configを起動、softwareメニューを選択、Softy を選択して 3rd party のソフトウェアをインストールします。

ソフトウェアの一覧の中に「OMV」があるので、これにチェックマークをつけて、インストールします。(かなり時間がかかります)

4.OpenMediaVaultにログイン

完了したらブラウザでOpenMediaVaultにログインします。avahiが動いているので、http://(ホスト名).local でアクセスできます。ユーザー名は admin 、パスワードは openmediavault です。ログインしたら、以下の作業を行います。

(1)パスワードの変更とネットワーク設定を行います。
(2)sshでログインして、fdiskでHDDの空き領域をLinuxのファイルシステム領域にして、ext4でフォーマットしておきます。(OpenMediaVaultでできるかと思ったけど、できなそう)
加えて、e2labelコマンドでラベルを付けておきます。

$ sudo mkfs.ext4 /dev/sda3
$ sudo e2label /dev/sda3 mirror

(2)「ストレージ」→「ファイルシステム」で、/dev/sda3 をマウントして共有できるようにします。
(3)「アクセス権の管理」→「共有フォルダ」で、/dev/sda3 の下に共有領域を作ります。このときに適当にその領域の共有名を付けます。
(4)「アクセス権の管理」→「ユーザ」で、Windowsファイル共有のユーザーを登録します。
(5)「サービス」→「SMB/CIFS」で、まず「一般設定」で機能を有効化、ワークグループ名を適当に付けます。その後、「共有」で「+追加」をクリックして、共有されるフォルダを登録します。共有フォルダは先程作った共有名で指定します。

“NanoPi NEO2にOpenMediaVaultをインストール” への3件の返信

  1. ともの様

    初めましてhuskyと申します。とのもさんのNanoPi NEO2にOpenMediaVaultをインストールを参考にして、Ambian busterからOMVを入れました。システムはFreindly ElecのNAS kit のHDDに移行しています。OMVを稼働させて再起動するときは再度ブートするのですが、シャットダウンをし、いったん電源を切り再度電源をいれるとブートせずシステムが起動しません。IPも貰えず、どうすることもできない状態です。何かアドバイス頂ければ幸いです。

  2. こんばんは。
    この頃は、Armbian Ubuntu+OpenMediaVaultは少なくともインストールはうまく行って、そこそこ動作はしていました。しかし、少し前に自分も20.04LTSとの組み合わせでインストールし直した際には再起動後、立ち上がってきませんでした。原因は少し追いかけましたが、わかりませんでした。
    ですので、自分は素のSambaで運用しています。素のSambaの方がOMVよりも圧倒的に安定していますので、Sambaにトライしてみてはいかがでしょうか。
    自分がインストールした際のメモをもとに、簡素な記事を作ってみましたので、もしよろしければご覧ください。
    https://tomono.tokyo/2021/03/13/9393/

    1. ともの様

      アドバイスありがとうございます。別記事をつくって頂いて感謝です。
      sambaにトライしてみます。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)